Toyota Celica Supra Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
9,658 Posts
williamb82 said:
thats not the oil pressure i have, its what i read was acceptable in either the chiltons or the haynes(dont remebr which at the moment). i just want to make sure when i build my other motor that it will be trouble free for at least a year or 2. i have a lead foot and drive the car very hard day in and day out. you can ask eric, paul, or dave, they will tell you. lol. anyhow, since im about to put the short block in my 84 i will try the shim mod to the oil pump. btw, ,anyone know where i can get a 5m pump cheap. i found one on toyotaparts.com and it was like ~$175. id rather not go broke on a oil pump for this block. i will definatly go oem for the race motor though.
william

William,to quote the Godfather of the SBC "Smokey Unick "sp"",any engine needs only 5-7psi of oil pressure per 1000rpm.At idle,many of my old Mopars ran 3-5 psi,and all the manuals of the day called this acceptable,never lost a motor that was not my fault :twisted:

As for your oil pump,I can supply a factory 5m pump ,shipped to your house,for aprox. the same as the one you found on toyota parts.com.They come in an afermarket box,and the the "toyota" is ground off the housing.I just priced them this week,$165 + shipping is what I can sell them for and not have the boss nibbling on my behind :D
HTH
 

· Registered
Joined
·
9,658 Posts
Christian,no worries as long as it's a good shaft,10 gte's with 5m pumps,gear/shaft not a problem.

William-check those spots I told you about,before you buy any parts.


All!!!, when installing a 5m pump,rotate crank,check for clearance.I have had the crank lightly rub 1- the main oil tube,at the "banjo",2- on the main body of the pump,in the area of the hold down bolt "don't know how else to describe".A bit of dremel work/grinder work has solved this issue.Not every pump/block combo does this-strange but true.

HTH
 

· Registered
Joined
·
9,658 Posts
white_mk_2 said:
Junkie said:
Christian,no worries as long as it's a good shaft,10 gte's with 5m pumps,gear/shaft not a problem.
So just to verify, a 7M shaft with a 5M pump will work? I'm putting my 7M back together so this is pretty important.

Thanks,
Yep
 

· Registered
Joined
·
9,658 Posts
Greg is correct,I forgot to mention the pan thing.That is mostly due to the fact,that the 85-6 pan is the only pan I use "85-8 Cressida is the same" unless the car is staying 5m,and not being modded.
The ONLY problems I ahve run across with the pump fitment,have been clearance issues with the crank at the "banjo" on the tube,and/or the base of the pump.Knowing this,I just assemble,rotate crank,find interference point,dis-assemble,grind,repeat :)
The funny/weird part about this little dilemma,and This isn't hard figures,but,spilt it into almost 1/3's -no grinding involved-grind the banjo/tube-grind the base of the pump.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top