Toyota Celica Supra Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
:shock: A 55 gallon fish tank for an 84 supra. Now is that a trade or what?
The guy said he was sitting and idling at a train track when it shut off and could not get it restarted. Had it towed home and never could get it started. It has set for a year or so. I am just waiting for it to dry up here in the south so the wrecker won't get stuck picking it up. Will let you all know what I find.
Glad to be part of this group.
 

·
Heroic Autobot
Joined
·
705 Posts
Now THAT is a trade. Welcome to the board and congratulations!
 

·
Registered
Joined
·
1,183 Posts
Do you know what is wrong with it?
 

·
Registered
Joined
·
7,111 Posts
wow that's a great trade, congrats and welcome to our little community here. There is only one thing that you might want learn how to do before you ask anything, learn how to use the Search button :wink: :p That will keep Forum Administrator :)fruit:). off your back :lol:
 

·
Registered
Joined
·
3,433 Posts
zankone said:
wow that's a great trade, congrats and welcome to our little community here. There is only one thing that you might want learn how to do before you ask anything, learn how to use the Search button :wink: :p That will keep Forum Administrator :)fruit:). off your back :lol:
lol

yeah welcome to the group and i'm glad that you got such a good deal.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Thanks

Thanks for the warm welcome! I will keep the search in mind when I post. Don't know what is wrong with it as of yet. I will keep you all posted and get some pics as soon as I get the car. Weather channel is still calling for rain everyday for another week. Might just have to push it to the paved road or something. Thanks again for the welcome!
 

·
Registered
Joined
·
1,855 Posts
You could talk me out of a fish tank for a mkii any day
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Got it home

I finally got the diamond in the rough home! Tried turning it over but nothing. Traced the starter wire and wouldnt you know it... its gone! Go figure. So I turned the motor with a breaker bar and the distrib turned. Looks like a couple of things are missing but all in all pretty much in tack.
Have to get a gas tank and sending unit for a dig dash. All window motors work, sunroof works. Only rust is on the hatch not bad though. Seats are in great shape everything seems to be working.

So now I am in search of a gas tank time to hit the junk yards.

I guess it is an L model but not sure it does have an auto trans.
I think I got a deal of a life time. :lol:
 
1 - 8 of 8 Posts
Top