Toyota Celica Supra Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
807 Posts
Discussion Starter #1
I've run into a problem installing the rear sway bar. I've looked at the swaybar install topic, which looks to be very straight-forward...but mine doesn't quite fit. The ends of the sway bar don't quite center over the mounts, making the end link drive through at an angle. This ,coupled with the end link bolt barely being long enough to thread the nut onto even under ideal fitment, doesn't allow any thread to make it to the other side. I'm looking for suggestions if others have run into this before.




 

·
Registered
Joined
·
2,634 Posts
Bolt up the endlinks first then the frame mounts and you wont have that problem. Also make sure the car is supported with jackstands under the control arm instead of the frame to keep the suspension compressed.
 

·
Registered
Joined
·
2,476 Posts
And you better go ahead and get the mounting points welded or beefed up because they'll break soon.
 

·
Registered
Joined
·
807 Posts
Discussion Starter #6
Andrew: No, they weren't hard to install other than my confusion with the endlink connection. By far the easiest of this weekends Eibach/Tokiko/Addco forray.

SupraWes: Ya know...I had that thought at one point, then it went away and never came back. I had supports under the control arms, but with doing it backwards, it just wasn't enough. All good now though. :)

Muchbzy: Agreed. I figured I'd address that when I let a shop do my bushings next weekend. Hopefully they'll last a week!
 
1 - 9 of 9 Posts
Top