Toyota Celica Supra Forum banner

121 - 140 of 168 Posts

·
Registered
Joined
·
171 Posts
Do any of you 7M conversion pros have an ECU pinout for the later model NA auto engines with the gray 22/16/26 pin ECU plugs? The diagram in the mk3 TSRM doesn't seem to be right and the only other pinouts I can find are for turbo engines or older models with different plug configurations.
 

·
Registered
Joined
·
172 Posts
Last first. The 43 is from when you had starter wiring wrong. The 32 is from the High Altitude Control sensor not being plugged in. This item is forgotten often. Its a small sensor that rides inside car, that plugs into engine wiring harness. Size of a small matchbox. Not sure of cause for 31, could be wiring, plug, airflow, or other. Try resetting computer by pulling EFI fuse or disconnecting battery overnite, then drive car and pull codes again.
Isn't the 7mgte starter wiring inbeded with the engine harness? Cause I'm useing the old 5m starter wiring wish is independent. Therefor I should allways get a starter signal cause I'm not going to the 7m. Right?
 

·
Registered
Joined
·
3,965 Posts
Discussion Starter #123
With this harness guide it intercepts the OE 5M start signal and sends it to the ecu and cold start. If you missed it well that sucks but it's in there. That's why this is V.3, V.1 and V.2 all had a few changes made here and there.
 

·
Registered
Joined
·
172 Posts
I know is a lot to ask, and I'm sorry. Could u go into more detail on step 3 relocation?
I installed the wire back and the hac sensor. But still have that AFM problem
 

·
Premium Member
Joined
·
6,102 Posts
You need a tach adaptor. Your car came with 1 coil and a distributor, and a tach that reads that signal. The engine you put in has 3 coils and no distributor, and doesnt generate proper signal for tach. From the first post on the first sticky in this section-----#10.MSD tach adapter.P/N 8920
 

·
Premium Member
Joined
·
6,102 Posts
Um, help how?
 

·
Registered
Joined
·
172 Posts
Ok maybe if I ask a question about it one at a time. First: when u de pin the black/orange wire from B1 it says to make reach old power supply for resistor my ??? Is wher is the old power supply
 

·
Registered
Joined
·
172 Posts
Found vaccum leak! And it runs much better and its more stable and drivable. But I still have takeoff hasitation and idles fluxuate.
 

·
Registered
Joined
·
138 Posts
Is there anyway you could give wire colors for the connectors? My harness had the two smaller plugs cut off because the previous owner was going 1J and needed the plugs.

Nevermind, I feel like king of the search button right now.
 

·
Registered
Joined
·
3,965 Posts
Discussion Starter #136
yeah I can do that for you guys. I can't tell you when I'll have it done as I'm busy with building cars in here in iowa.
 

·
Registered
Joined
·
52 Posts
regaurding step 3:

"De-Pin the Black/Orange wire from the middle of the B1 connector. You'll want to move it so it'll reach your old power supply for either the Injector resistor or the Ignition Coil. To make this plug and play you de-pin the single pin connector that once attached there and slide the 7M wire into it. Now you can remove the 6-pin connector in the engine bay. DONE."

OK i have de-pinned the black/orange wire from b1 connector. after that what do you mean by "move it" as in exposing the wires from the harness to move the power suppply? or do i just simply solder a new wire to the end of that one and run it to the engine bay?
also i have the coil pack power supply for the 7mgte with the 2 green conectors, but will the 5m coil power thing that bolts to the shock tower work or do i need the 7mgte one?
 
121 - 140 of 168 Posts
Top