Toyota Celica Supra Forum banner
1 - 2 of 2 Posts

·
POTATO
Joined
·
17,346 Posts
Discussion Starter · #1 ·
ugh, what a weekend! Sorry, no pics, damn digicam took a crap at the last minute. Anyway, it was a slow start. Saturday night we got the head pulled on the Blupra...
Sunday morning...
we pulled the block out of the Blupra and pushed it to the side. Finally, we started dismantling the Blackpra. Got the head off, laughed at the toasted combustion chamber, went back to work. K, well we wanted the harmonic balancer off the Blupras engine b/c ours was chipped, WELLLLLL, what a surprise when we took the harmonic balancer off the Blackpra and a pretty bent up keyway fell out. This is not good we thought. Well, the timing gear, the crank, and the keyways were all toast, just practically obliterated. It's amazing that the car actually still ran. Now I finally know what the damn tapping noise was. So after pulling a minor temper tantrum, we admitted we had to change cranks out as well, and had to pull the block from the Blackpra. We worked through the night until 6am Monday morning until we couldn't see anymore, we had gotten the #4 piston replaced, all the pistons wire brushed clean, head cleaned, got the block back together w/ the 84 Blupra crank, its used bearings, :oops:
went home, slept for 4 hours, got back at 10:30am.
The Blackpra fired up after all the damn details were finished finally at 3:30pm Mon. Idle is perfectly smooth, no more hideous tapping, no more oil leaks, just purrrr ( well actually a grrumble beings I have a hole before my muffler now, heh )
All in all, it took about 14-16hours total to get the Blackpra stripped, rebuilt and started up, and everything in the middle.

I also learned a few things too *gasp*
Most important:
An engine is hell to put back on a manual transmission :?

Some 84 5 speed P-type parts will not match w/ 85 5 speed P-type
1. the 84 oil pump pickup line will not bolt on to an 85s oil pump, go figure!
2. rod caps are marked differently ( I forgot which engine was which with epistons laying everywhere) but one engines rod caps are marked w/ arrows, the other w/ numbers
3. throttle posistioning sensor doesn't match/ will not bolt up, another go figure

just a lil' info I thought may sound interesting
Thank God my baby's back, that's all I care about, now onto the other stuff:
I still have to fix drivers rear lower control arm, rear shocks, and the stabilizer arm bracket in the front, it actually fell OFF the frame this weekend, :roll:
 

·
POTATO
Joined
·
17,346 Posts
Discussion Starter · #3 ·
I'm up to it, if you can stay up all night we can do 2 engines :p
Gawd, what took us so long was looking for the damn tools, it'd take me 20 minutes to find a 10mm after my b/f used it an hour ago, it went on like that the whole time. More time was wasted looking for stupid crap than actually working, heh
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top