Toyota Celica Supra Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Recently replaced head gasket. Had trouble with fuel injectors, replaced all and all cylinders fired. Was running very Rough still. Replaced oxygen sensor, started running a bit better but still rough. A couple days later, vehicle is running extremely rough. Hesitating on acceleration, limited power, and shaking. Any ideas? Could this potentially be a vacuum leak? We also sealed up all SMOG ports, don’t know if that could have affected it.
 

·
Registered
Joined
·
142 Posts
Not a lot to go on here, but start with all the basic stuff like making sure all your plug wires are on in the correct order, and properly connected. Shaking often indicates cylinder(s) not firing. Or if you replaced all the injectors, make sure the o-rings didn't tear.

So, either way too much fuel or not enough spark. I'd start with spark and vac leaks

Why seal up smog ports?
 

·
Registered
Joined
·
574 Posts
Exactly which smog ports did you seal up?
What problems did you have with injectors?
Why would they go bad between working perfectly before BHG to bad after headgasket fix with zero miles in between?


1. did you measure head and deck for flatness when replacing headgasket? How flat were they? 0.1mm? 0.05mm?

2. Do compression-test. There may have been piston, ring or bore damage from BHG.

3. test injector harness. Disconnect all injector connectors. Key ON and measure both terminals of each injector connector. Do you get +12v on one terminal and ZERO volts on other? If not, you've got damaged and shorted injector wiring. Not uncommon when doing headgasket job as that requires manipulating injector harness lots. Old crispy wiring is on last legs and moving it to do headgasket job is final blow.

 
1 - 3 of 3 Posts
Top