Toyota Celica Supra Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
:shock: Here's a new one...Yesterday, my speedo starts reading 20-30 MPH over what the car is doing and maxes-out at about 45MPH! (85+) I've never seen a speedometer start failing to the high side like this...Any ideas? I also have a digital dash standing-by if the speedo is bad...does anyone know of a resource for info on changing-out an analogue for a digital dash? Thanks, All! D-[/b]
 

·
Registered
Joined
·
793 Posts
From what I heard it is damn near impossible. Replace the cable, if it still does it, test your gauge itself (not sure how to do this though) If it checks out, Id see if your speedo gears are okay. Other than that, good luck!
 

·
Registered
Joined
·
1,183 Posts
Now might be a good time to get a 130mph speedo out of an '84-86. If it does the same thing, then swap the speedo cable as was suggested, and check the speedo gear.
 

·
Registered
Joined
·
73 Posts
My speedo seems to be about 5-10 mph less then my actual speed... is this just my car or is this common? The needle also wobbles at low speeds. Both of which aren't big deals, just wondering if it's just my car.
 

·
Registered
Joined
·
9,445 Posts
What are you running for tire sizes???
 

·
Registered
Joined
·
9,445 Posts
Supra DII,

We don't have a procedure to swap out a analog dash for a digital dash, because we don't recommend it. MAJOR PITA to do it.... Not a plug n play job, you need to change the cluster wire plugs, you need to change out the oil pressure guage sending unit for thingy that works w/ the oil pressure idiot light that comes w/ the digital dash.... And you also lose your voltmeter guage, because you get a idiot light in it's place..

Trust us, WE HAVE Digital Dash peeps who wish they had the Analog instead!!!!

If you're speedo is reading high all of a sudden, check your cable, or test the speedometer sensor & see if that's died??
 

·
Registered
Joined
·
4,871 Posts
I would check for a problem in the speedo itself for starters. The analog speedo is mechanically driven directly by the speedo cable, which makes me think that either something is binding on the rotating assy. in the speedo or perhaps the hairspring has broken.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #8
:D Thank You all for the brain power committment to this problem! I will leave the digital dash where I found it and begin with a speedo cable lube, (cable is about 4 years old) then graduate to a close inspection of the speedo unit itself. Worse come to worse, I'll do the 130mph swap-out, and I have a replacement tranny waiting for a reason to be installed if it turns out to be the tailshaft speedo gearing. Again, thanks, all! D-
 

·
Registered
Joined
·
40 Posts
Discussion Starter #9
Hey guys, I took your advise and swapped-out the guage cluster for a 130 MHP unit and it fixed the problem...now I need to find a 3.73 rear end to make the thing read correctly and raise my top speed to over 65 MHP!
Thanks Again, SDII
 
1 - 9 of 9 Posts
Top