Toyota Celica Supra Forum banner
1 - 7 of 7 Posts

·
Premium Member
Joined
·
25 Posts
Discussion Starter · #1 ·
recently my alternator went bad. I have since replaced it along with the battery and serpentine belts, and tensioned everything. before this i have replaced the spark plugs, and verified that my fuel pump works. I have also replaced my mass air flow sensor and checked the throttle body. the car refuses to turn over. all power comes on as normal, but it just won't turn over. i replaced the starter just to be sure. no changes. the car started just fine until the alternator went bad, so I have hit a wall and am at a complete loss. I have a 1985 p type with a 5mge.

Please help!
 

·
Registered
Joined
·
251 Posts
Battery voltage measured at battery during cranking (or trying to crank)? Voltage at starter?
Is there a start-inhibit switch somewhere maybe (automatics do have it, no?)?
 

·
Premium Member
Joined
·
25 Posts
Discussion Starter · #3 ·
Battery voltage measured at battery during cranking (or trying to crank)? Voltage at starter?
Is there a start-inhibit switch somewhere maybe (automatics do have it, no?)?
I haven't tried that yet. I'll let you know. Car is manual. Unsure about a start-inhibit switch.
 

·
Premium Member
Joined
·
8,377 Posts
Are you getting power to the starter?? Did you bench test the starter prior to install??
 

·
Registered
Joined
·
281 Posts
If you have power in acc and ignition key position than there is nothing wrong with fusible links.
I would first test for 12v at solenoid wire to starter (terminal 50) when turning key to starting position.
If 12v that would only leave a bad starter cable wire from battery or a bad starter or ground wire to engine block.
 
1 - 7 of 7 Posts
Top