Toyota Celica Supra Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
586 Posts
Discussion Starter #1
Hey all, Within the last few weeks my car developed a motorish whine when i start up when its cold. Gets louder when i turn the steering wheel but doesn't go away till it warms up a bit. Whats the deal....do I just need to add steering fluid and if so where the hell does the steering fluid go??? Seriously I've looked and I don't see anywhere where you would put power steering fluid.....everything is caked with oil under the hood but your help is seriously appreciated!

Shawn.
 

·
Registered
Joined
·
4,517 Posts
You should probably also take a quick look and make sure the liquid is clear - i.e. there's nothing stopping it from moving in the system. Any idea when it was last changed?
 

·
Registered
Joined
·
586 Posts
Discussion Starter #4
I've had the car for just over 2 years and I haven't put any in it. I'll take a look at the fluid and let you know. Do I put in power steering fluid or Dot 3 brake fluid....think thats what the cap says?
 

·
Registered
Joined
·
2,072 Posts
Power steering fluid or Dexron 3 auto trans fluid, NOT BRAKE FLUID! Please get hold of an owner's manual (glovebox) where there is info on all fluids and capacities. Once you've done that a workshop manual would also be good reference - available online N/C.

Bo
 

·
Registered
Joined
·
5,448 Posts
Power steering fluid or Dexron 3 auto trans fluid, NOT BRAKE FLUID!
Funny you say that since you should also not use the typical power steering fluid.

You only want to use Dexron 3 like you said.


Also to the OP, drain out the old fluid, use a flashlight and see if the screen in the pump is clogged at all.
 

·
Registered
Joined
·
586 Posts
Discussion Starter #7
Ok, so Im guessing the aluminum can looking thing is the resivoir for the fluid. I've looked in and the fluid in it is dark in color. Also it seems to only be about half full. Wheres the fill line? It also says to use Dot 3 brake fluid on that cap??? Am I looking at the wrong thing....if so i don't seem to see anything else that could be it as this is atached to a pump run by the serpentine belt. I do have a chiltons manual....not sure where, need to dig it out.
 

·
Registered
Joined
·
2,072 Posts
I'm just guessing here but perhaps the proper cap was lost and replaced with a cap from a brake master cylinder. The proper cap is metal and has a dip stick attached to it for checking the level. I have spare power steering pumps here - $10 + postage buys one, so if yours is pooched just plug'n'play.

Bob
 

·
Registered
Joined
·
586 Posts
Discussion Starter #9
Yeah, looks like the wrong cap. The one I have on it is a translucent plastic one with no stick attatched to it....dont' even think it belongs on this car cause it looks nothing like any other cap on the car! Just off the top of your head, when looking inside the canister where should the level be? Like I said, mines about 1/3rd full now. I have no way of draining the system now so any help is appreciated....
 
1 - 10 of 10 Posts
Top