Toyota Celica Supra Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
216 Posts
Discussion Starter #1
Well I installed a stereo (dont know how I managed to...) in the supra. It looked like nothing had been installed in it for about 10 years :? Anyhow It was working for about a week then all of a sudden whil elistening to it it just stopped. ALong with that my headlights wont go up anymore either (happedned same time)... Ive since checked all fuses and none in the entire car are blown. Check all connections and wiring and the fuse in the stereo and everything is fine :!: Any ideas? thanks

Austin
 

·
Registered
Joined
·
4,871 Posts
Do your power side mirrors still work? How about the cigarette lighter, hazard lights and the horns? The HAZ/HORN fuse supplies power to the headlight retract control relay.
 

·
Registered
Joined
·
793 Posts
Check you tail/brake lights. When I installed my first deck, I shorted something and my tail lights stopped working! Dont ask how, just did. The officer wasnt very nice about it, but I did get away w/o a ticket :)
 

·
Registered
Joined
·
216 Posts
Discussion Starter #4
Thanks a lot Dave! I will check that tomorrow morning. You now ever since I got the car the hazards nor cigarette lighter have worked. I checked for power to the lighter and I had it, but the hazards I havent checked. The horn however has always worked and so do the mirrors and brake lights :mad:

So maybe the hazards/lighter have somehting to do with it cause what a coincidence... thanks Ill update tom.

Austin
 

·
Registered
Joined
·
216 Posts
Discussion Starter #6
I havent checked it yet cause I did soem other stuff to it today. I picked up a bumper, 2 sunroofs, all the trim, power steering cap and a new boot all for $30 from the toyota auto salvage. I did that then changed the tranny fluid with some BG Syncroshift (works great 8) ) Put some lightweight shockproof in the rear and blead the brakes so it was dark by the time I finished. But I did check everything... the hasards, cig lighter, horn and stereo all do not work right now??? So I guess its the hazard lights fuse eh?

Austin
 

·
Registered
Joined
·
2,100 Posts
Try replacing that fuse even if it dosent look blown. Some times the fuse will go shouth and you won't be able to tell by looking at it.

will
 

·
Registered
Joined
·
216 Posts
Discussion Starter #8
Allright I need to know which fuse is the one I need to replace. I am missing the cover to the fuse box inside the engine bay so i do not know which one is the hasard light sue. So if anyone can help me out and tell me which fuse I need to replace I would appreciate it it a bunch, thanks

Austin
 

·
Registered
Joined
·
216 Posts
Discussion Starter #9
Come one guys the Haynes manual's dont say what the individual fuses are so I need you guys to tell me which one. THanks !

Austin
 

·
Registered
Joined
·
216 Posts
Discussion Starter #10
Ok well I found the fuse. The reason I was asking is cause my car is exactly as the name says, and I dont have any fuse labels/covers for anything. Anyhow I went to the junkyard again today and found a fuse cover from a 83 or something and it only had two legible fuse labels on it and one of the happened to be the hazard fuse :D

So I got it fixed now and everything is working great! Thanks for anyone who helped earlier...

Austin
 
1 - 10 of 10 Posts
Top