Toyota Celica Supra Forum banner

1 - 20 of 40 Posts

·
Registered
Joined
·
224 Posts
Discussion Starter · #1 · (Edited)
this is my baby.

picked her up Thursday and love it. right now, I'm trying to get her to start on her own, It would crank and sputter, so today, I went ahead and sprayed some starting fluid in and she started right up, warmed up, and idled down, so I'm thinking maybe a sensor or cold start injector, but ill figure it out, I've been using the search function on the forum and have found some good posibilities. Before that i was dealing with a really loud "clanking" sound that i was assuming was valve noise and after warming it up and playing with the throttle, it has gone away, I'm really glad it went away i was praying for air in the lifter lol and not a rod-knock. It feels great to start with a running vehicle. well, ill update as i fix and fiddle with stuff, that's all for now.

SouthTexasSupra.
 

·
Registered
Joined
·
2,121 Posts
Looks good. It has the hockey stripe so it looks like it came from the east coast if im not mistaken. Or southeast?
 

·
Registered
Joined
·
637 Posts
try cleaning the plug on the cold start injector sensor located in the thermostat housing, worked on my 83 should be the same though? never hurts to clean connections though so might as well. good luck.
 

·
Premium Member
Joined
·
4,082 Posts
thanks everyone, i would rather it been a P than an L for the rear end gearing and horsepower so yet another thing to be exstatic about.
Horsepower is probably about the same. Rear end is def. the same between 5speed Ps+Ls. Ptypes have better seats and more clearance for bigger wheels and tires though!
 

·
Registered
Joined
·
5,448 Posts
Welcome. Thats a P-type. Not an L.
thanks everyone, i would rather it been a P than an L for the rear end gearing and horsepower so yet another thing to be exstatic about.
Um, I will say it again, the one you have pictured is a P-type, not an L-type, HUGE giveaway are the fender flairs, unless if someone went through the hassle of swapping fender flairs on it.

Unless if I just read your post wrong......

And it is a nice Supra also, one of my fav color options.
 

·
Registered
Joined
·
3,721 Posts
Nice color! If you want some ideas on looks, check out Tanya's "Coyote Ugly" thread. She had an 84 like yours, right before the black Supra she has now.
 

·
Registered
Joined
·
224 Posts
Discussion Starter · #13 ·
lol, so heres what happned today. yesterday was botched due to the battery in my multimeter taking a dump, no time to get one before work. So anyways,I check the TTS and it reads 48 between the terminals, and 100 grounded, outside the requirements of the tsrm, so i check the coolant sender, just fine, awesome, so i call and price the TTS from Toyota, those buggers want like $170, i dont think so. so i went ahead and popped the key in the ignition, and try and start it since i hadn't since like saturday night, and to my surprise, it starts right up! i was like "WTF?" and whats more surprising is i did it with the TTS UNPLUGGED, oh and the clacking is back. But i think the lifter is noisy due to the ubber heavy oil the PO put in it for whatever reason, i think they also tried some LUCAS or something to try and swell the seals, but no dice. oh and thanks for the link to the TSRM's. Thats all for now.
Later,
STS
 

·
Registered
Joined
·
224 Posts
Discussion Starter · #14 ·
well, i've done some basics plugs, cap,rotor, oil changed, runs better, but that dang lifter keep sticking intermitently. i've been turning it on everyday twice, letting it warm up and run. it pours oil out (not an exageration) the front from somewhere, and wont be taking any spins in it till i can change whatever seal is leaking. definetly need to check the pcv system, i pop the oil cap off and and it smooths out some, and nice little puffs of smoke come out rythmically with one of the cylinders. a compression test may be in order. it doesn't seam to be burning any oil in the exhaust as theres no smoke, sometimes though it runs pig-rich and smokes for a second then clears up.
thats all for now,
STS
 

·
Registered
Joined
·
515 Posts
Sounds like too much pressure in the crank case caused a seal to go bad. Is it an upper or lower engine oil leak?
 

·
Registered
Joined
·
3,721 Posts
The camshaft seals are known to blow out of their bores and pour oil out the front of the engine (and also gets the timing belt all oily). Easy to check by pulling off the upper timing cover to inspect (five 10mm bolts to get it off). The seals might be okay, just need to be tapped back into their bores. The high crankcase pressure could have unseated/blown them out, so that will need to be fixed at the same time. Good luck!
 

·
Registered
Joined
·
2,352 Posts
Put some Marvel Mystery Oil in the crankcase. Should eventually help with the valve lifter noise. Also run some fuel injector cleaner through the gas tank, and try running some SeaFoam through the intake through the brake vacuum hose at the rear of the engine near the driver side firewall.
 

·
Registered
Joined
·
401 Posts
congrats and welcome. minus those engine issues looks to be a sweet supra. Post more pics if you get the chance. Good luck tracking down the oil leak. I'm sure you'll get it figured out.
 

·
Registered
Joined
·
224 Posts
Discussion Starter · #19 ·
thank you everyone for the info. the oil looks like it is leaking around the front of the oil pan, but as steady as it flows, i think yall are right about the camseals, it makes sense that it would pour the oil out, collect in the cover and pour out near the front/oil pan area, ill pull the inspection cover first chance i get, and get some pics too. everyone have a safe Christmas.
STS
 

·
Registered
Joined
·
224 Posts
Discussion Starter · #20 ·
well, no pics, but i did pull the inspection cover, after letting runn a little, and it oil was built up on the passenger side camgear, so, i shielded my wifes scion from any oil that mite fling off and i started it up again, and there it was, a nice new bead of oil around the cam seal and slowly making its way down the cover. I'll be changing the cam seals, does anyone have any suggestions for other things to replace while i have the front apart? i am going to get that felpro camseal kit, it comes with the cam-seals, and "dust-seals". im almost tempted to do the intake and exhaust gaskets. what do you guys think?
STS
 
1 - 20 of 40 Posts
Top