Toyota Celica Supra Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
So I finally got the car put together enough to drive it around for a day or so. but when pulling into my yard the other day it seemed like the throttle had got stuck open as the car started to accelerate very quickly right after i took my foot off the gas pedal turning in, when I put my foot on the clutch it seemed to make it worse and redline, so I just had to shut the car off and let it just roll the rest of the way in.

First things I checked were the gas pedal and the throttle linkage, there is no nut missing and everything else looks fine physically. The speed control actuator is what is opening the throttle all the way any time I turn the ignition over. All fuses are the correct size and none are blown. So is it most likely the ECU shorted out? Is there any other problems that could be causing this? I can't find much more information on here other than the nut on the throttle linkage cause and the ECU shorting out.

I'm about to go back home with the ECU voltage and resistance values and check them, but will it work to use the values in the online MKII TSRM for an '82? The wiring diagram is different from any other year (just fyi to anyone who might not already know) and although I have the '82 wiring diagrams, I do not have '82 specific data for the ECU voltage and resistance values. Does anyone on here have this information and know whether or not it is the same as what is provided in the online MKII TSRM??
 

· Registered
Joined
·
41 Posts
Discussion Starter · #3 ·
Oh Yeah I'll check into that too, I remember seeing some posts about that but not sure why I disregarded them. It's possible for the cruise control to be like stuck on or something so right when the engine turns over the throttle opens all the way?
 
1 - 2 of 2 Posts
Top