Toyota Celica Supra Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,956 Posts
Discussion Starter #1
Ok Mabey I should ask in the engine section, but anyway---
I have an 85
I have recently developed a clicking sound in the engine when its running...Idle speeds and all others. I have been able to trace it to somewhere with in the lower area of the timing belt pully set up. I think its the lowest pully(crank?) Timing belt look like its in good shape all the bits under the cover seem to be tight.
Before I put my car out of comission for a while I was just trying to see if you guys might have any opinions.
 

·
Registered
Joined
·
1,956 Posts
Discussion Starter #2
Well its not the Idler Pully, just changed that out......

One item of the list.
 

·
Registered
Joined
·
4,871 Posts
Check your crank pulley bolt and see if it's loose. Sounds like the keyway in the timing belt drive sprocket on the crank may be your problem.
 

·
Registered
Joined
·
2,476 Posts
CRANK!! Mine did this and I couldn't find it and my crank broke and the balancer fell off and I had to replace the crank!
 

·
Registered
Joined
·
147 Posts
Hmm...my engine has a fast clicking sound as well. It seems to be coming from where the injectors are. I know the injectors are supposed to make a clicking sound when you listen to them with a stethoscope, but do they ever make that noise out loud? Or maybe this sound is internal from something inside the engine?

Any idea's??
 

·
Registered
Joined
·
191 Posts
i just took my 5m-ge appart and realixed I currently have the same prob...the keyway wore the crank., and the balencer.. i was woundering if i can fix the crank and or weld the key way in, and file to fit. and buy new balencer,, 1 question, how much ruffly is balencer/ crank...
 

·
Registered
Joined
·
4,558 Posts
nights... i had a similar sound, and i found it to be a burnt lobe on the cam.
maybe pull your cam covers and check them, its a real easy way to cross one thing off your list of trouble spots.
 
1 - 7 of 7 Posts
Top