Toyota Celica Supra Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello fellow supra fans,

I have already posted this question on mk2 (yahoo groups) but I just thought that I'd go ahead and post it here too since I still haven't been able to solve the problem.

I need to pass smog and I can't because I am having a problem with the timing check connector on my '84. When the connector is shorted, nothing happens. The smog guy tells me that what is supposed to happen is the idle is supposed to change, the timing is supposed to retard and the check engine light is supposed to come on.

I have tried shorting the connector both before and after the car is running as well as before and after the ignition is turned on. The check engine light never comes on otherwise, so there are no trouble codes stored in the ECU. I have replaced both the O2 and TPS sensors, I have used a multimeter to check the connectivity of both wires coming out of the connector itself [one to the ECU and the other (ground) to the intake manifold], and I have checked and tested all of the fuses and relays.

I am really lost here as to what to do next. I don't have a load of money or patience to deal with a mechanic around here. Keep in mind that I am in California, so there's no way that the smog guy will let this little problem slide. I had no trouble passing the emmisions test or the visual inspection. This is the only thing that is keeping me from passing. The car runs great otherwise and I'd hate to have to give her up.

If I am missing anything or if you know what I could try next, please let me know.


Thank you,

Dan
Black '82 p-type
White '84 p-type
 

·
Registered
Joined
·
9,840 Posts
Dan,he has 1/3 of it correct.The idle will not change on the older cars.The timing does not retard,just stabilises (sp).But,the check engine light should come on when connector is shorted.I have seen several that act like yours,but our smog tests don't require all that BS,so I have never looked into it any farther.Sorry can't be of more help,maybe some else can add more comments?
Shawn
 

·
Registered
Joined
·
1,613 Posts
This is gonna sound like a smart ass question, but I am being serious. I know I tend to miss some of the seemingly inconsiquential details when I become so involved in the major ones that over look simple stuff...

Does the check engine light work?

I once spent $700 trying to fix my charging system... over a broken 35 cent fuse.... :oops:
 

·
Super Moderator
Joined
·
8,363 Posts
Have you tried to see if you have got voltage across the check terminal? The check connector IIRC comes straight from the ECU. So if you have no juice you should look for a bad wire connection. BTW have you checked the timing? If the timing is in spec you should be able to get it to pass. If so I would try another less anal smog guy.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Yes, the check engine light works because it comes on when I turn the key before I start the car. I have checked the connectivity of the wires to the ECU using a multimeter. I know that the wires from the connector are good. The timing is set to spec with the connector shorted, but he still wouldn't pass me. Maybe you're right... I should try another smog place.


Thanks,
Dan
Black '82 p-type
White '84 p-type
 

·
Boost-a-holic
Joined
·
2,560 Posts
If anyone comes up with a way to fix this, clue me in also. I have the same problem with my car, but since the timing's in spec and it passes the other tests, I've never been dinged on it (though one guy did mention it as a potential issue).

TIA -- Bob
 

·
Registered
Joined
·
7,111 Posts
I also have the same problem on my 85 mk2. The problem with my car is that the check engine light turns on and stays on. When i do that check engine bypass it wont blink or anything. Then another thing about my car is that the timeing is all F'ed up. when i put the timming light on my Pully it reads it right at the very top center of the pully WAY over where its suppose to be. :cry:
Now im getting worried because time is nearing to reregister my car and CA DMV (Smog Nazi state) is probably gonna make me go smog my car.:x
Now dont get me wrong but my car is running nice and strong.

hope u guyz and galz can help
Thanks, Laterz
zankone
 

·
Registered
Joined
·
667 Posts
OPen and Closed Loop? What does that mean?

MY 83 P-type will drop rpm when i put the jumper in but no check engine light. I know the light is good, I can see it before i start the car up.

My question is> WHat does Open loop and closed loop mean and how can I confirm it is working... Right now my car runs well but I have the timing advanced to about 15-17 degress and there is no knocking or pinging on regular gas. Does this mean I can advance it more ??
 

·
Registered
Joined
·
1,613 Posts
Open loop and closed loop refer to fuel delivery maps.

In closed loop mode, the ecu monitors all the sensors(o2 sensor, tps, AFM, engine temp and a couple of other), and adjusts the amount of fuel delivered to the intake according to the real time readings of these sensors.

Open loop is a condition that the motor basically ignores all these sensors and relies only on a pre-programed map. Usually, open loop is only used at Wide Open Throttle (reffered to as WOT), and is activated when the Throttle Position Sensor (TPS) senses that you have pushed the gas pedal to or passed the point that it requires to activate it.

For more info, I recommend you pick up a book called "Bosch Fuel Injection" by Charles Probst SAE. Great book that contains more info on fuel injection than the average person could ever need to know :)
 

·
Registered
Joined
·
4,517 Posts
Smog guys...

Is this something the smog guys just "knows" or is it in writing some place?
Have you tried a different smog guy in a different place?

It might be the guy and not the test, if you know what I mean. :wink:
 

·
Registered
Joined
·
4 Posts
Discussion Starter #11
Well, the thing is is that the car went to test a while ago and came back as a gross poluter. In the wonderful state of CA, once this happens, you must go to a TEST ONLY station where the guys there are not allowed to help you in any way, they just tell you whether you pass or not. I've done some work on it since and it passes emissions just fine, but these TEST ONLY stations watch closely to every vehicle.
 

·
Registered User
Joined
·
3,283 Posts
dval43 said:
Well, the thing is is that the car went to test a while ago and came back as a gross poluter. In the wonderful state of CA, once this happens, you must go to a TEST ONLY station where the guys there are not allowed to help you in any way, they just tell you whether you pass or not. I've done some work on it since and it passes emissions just fine, but these TEST ONLY stations watch closely to every vehicle.
that's about ass backwards...
 

·
Registered
Joined
·
7,143 Posts

·
Registered
Joined
·
4,871 Posts
[quote="mwebber
that's about ass backwards...[/quote]


I'll second that! Did the car pass or fail the "test only" facility? Why is the tech monkeying around under the hood in the 1st place?
 

·
Registered
Joined
·
7,143 Posts
Yes, more than a year! and I wasn't on the forum at that time.
It's just that there is some valuable info written long ago that is worth reading about. Have no clue about the smog test though...
 
1 - 16 of 16 Posts
Top