Toyota Celica Supra Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
310 Posts
Discussion Starter #1
I had to edit the post last time i ask zank to post.
Well today i checked no timing on my car. When i did the bypass the engine light gave me a code (41), which is the TPS. So i reajusted it the way i know and still gives me TPS code. Does that mean that my TPS is bad. Lately i have not felt my engine wright its one of those things where you know something is not wright know what im saying. That do u guys think.

Thanks in advance :)
 

·
Registered
Joined
·
191 Posts
if it is giving you tps codes, check the wires for cracks or corrosion, or y gotta replace it.. i have no idea how much cuz im a new owner of an 85 5m-ge and have not had to replace it yet...
 

·
Super Moderator
Joined
·
8,392 Posts
HCogeHC said:
Does that mean that my TPS is bad.
Probably. I'd perform the check described in the manual. You'll know for sure then. More than likely the idle switch is worn out, especially if the timing is jumpy. FYI, a new Toyota TPS is a smidge over $100 from Jeff. HTH
 

·
Super Moderator
Joined
·
8,392 Posts
No, there is a switch built into the TPS for when the throttle is closed.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #6
Well my timing is perfert. The only problem ive noticed is the engine not running wright its hard to explaine. Another thing i noticed this morning was when i was at a complete stop and i moved the steering my rpms came down to alitttle under 500.
 

·
Registered
Joined
·
191 Posts
thats just cuz of the power steering taking load of the motor... no worry.but running rough???
 
1 - 7 of 7 Posts
Top