Toyota Celica Supra Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Hey everyone,

Because of the nice 12 degree weather we've been having here in Toronto, I thought I would take my 85 Supra out for a quick spin after being stored in the garage for 5 months. After about five minutes of cruising, I notice that both the charging and brake lites on the dash were flashing. Strangely, the car was driving beautifully!

I'm thinking that I didn't tighten the negative terminal enough, but if anyone has any ideas or has experienced this let me know.

Thanks,

Hosam
 

·
Registered
Joined
·
991 Posts
Indicator that your alternator is failing. Could be loose/corroded battery terminal but if tightening that doesn't fix it immediately, then I'd say your alternator is going south.

Leslie
 

·
Registered
Joined
·
1,537 Posts
lights

That indicates alternator is failing.

Tighten connections, see if it goes away. If lights stay on, you won't get far before the EFI systems, lights, etc drain your battery and you will be stranded.

If you need an alternator, let me know. I have a spare one here from an 85 that I would sell. I'm in Hamilton.
 

·
Registered
Joined
·
1,613 Posts
Correct me if I am wrong, but since he had the brake light also, doesn't that indicate voltage regulator too?
 

·
Registered
Joined
·
57 Posts
Did you check to see if the alternator belt was tight? If it feels loose, then I would suggest tightening it and see if the lights go out. Do you have a multimeter? If so, connect the multimeter (make sure to set it to read DC volts) to the battery and run the engine. With the engine running, a good alternator will put out about 14 volts. If it's less than 13 volts, then the alternator definitely needs replacement.
 
1 - 6 of 6 Posts
Top