Toyota Celica Supra Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2,634 Posts
Discussion Starter #1
I finally got it all finished this afternoon. The weird thing is it hesitates badly if I rapidly accelerate like I want to move. Sometimes I can get on it and it will hesitate then accelerate some then hesitate again then acclerate again. If I drive it granny style and slowly ease onto the accelerator then it runs fine. It almost seems like a TPS problem but why does it work when I accelerate slowly. I guess tomorrow I will check TPS, EGR, Compression, Distributor. I have already stared at it a while and cant find any loose connections or vacuum lines, the intake pipe is well secured. Im also not sure the upper intake manifold sealed well to the lower manifold, I dont hear any leaks and it pulls 20" of vacuum at idle but I'm not sure. t
 

·
Registered
Joined
·
1,457 Posts
It can be a number of things (which you mentioned) INCLUDING the tps. Depressing the gas quickly causes a big drop in vacuum/increase in pressure, and the ecu must compensate with more gas. Acts much like the accelerator pump on a carb.

Christian
 

·
Registered
Joined
·
310 Posts
well i kinda had a simillar problem only dif was that my car hesitated if i accelerated slowly somewhere between 2000-3000 rpms. I think that the problem was my TPS. I had problems with my timing and was told it could be the TPS and sure enough it was and it also solved my hesitation pro. Good luck i know how it feels when you finish overhauling a car and have these type of problems.
 

·
Registered
Joined
·
290 Posts
My car has the same hesitation problem sometimes. How much does a new TPS cost? Is there a way to test the TPS?
 

·
Registered
Joined
·
7,111 Posts
SupraDOHC said:
My car has the same hesitation problem sometimes. How much does a new TPS cost? Is there a way to test the TPS?
I think you just adjust it. its the little black box next to the TB.
 

·
Registered
Joined
·
2,634 Posts
Discussion Starter #6
Im actually hoping its going to be EGR, I think it may be bad, it was all plugged up and I cleared all the ports out. I will put the block off plates back on and see what happens. I cant really see it being TPS on my car as I swapped the whole throttle body from my old intake onto the new ported one. I didnt touch the TPS other than unplugging and plugging it back in.
 

·
Registered
Joined
·
290 Posts
I've got an 84 toyota repair manual so i'll try and test it and adjust it according to that tomorrow. I had no idea you could adjust :?
 

·
Registered
Joined
·
2,634 Posts
Discussion Starter #8
Problem found, fixed itself!!!

Well heres my theory on what happend. The hesitation started happening less and less as I drove it and now it is gone completely. I had the check connector jumpered tonight so I could set the timing, it was at 5 degrees DOH! and when I got back into the car I noticed it was flashing codes 41 and 42. Well 41 is TPS error, suprise suprise. 42 is vehicle speed sensor, not sure why that was there but maybe it was when the car was bucking back and forth and stalling and such. Anyway while I had the throttle body off with the TPS still connected to it I hosed it down several times with carb cleaner before putting it on the new intake. MY theory is that some of the cleaner got in there and reacted with the contacts in there somehow causing it to not work properly at first but now they have cleaned themselves and it works fine. Now to replace the junk lifters I put in there with the ones off the old head that I know are good, and install the header.
 
1 - 8 of 8 Posts
Top