Toyota Celica Supra Forum banner

1 - 20 of 35 Posts

·
Registered
Joined
·
1,181 Posts
Discussion Starter · #1 ·
Drove the car all day with no problems. Drove about 30miles yesterday and didnt miss a beat, even destroyed some guy stuck in the 80's with his Z31 lol. Got about a mile away from the track, sitting at a red light, light turned green and boom, screeeeeeeecccccchhhhhh. WTF was that?





PS pump siezed and ruined my sweet aluminum pully:sadsmilie. Not sure why it siezed though. I know that the rack was bad and even with the ps pump pumping I still didnt have any power steering. I thought it was the rack that was bad, so I assumed as long as I had fluid in the pump it would be fine but I guess not. Any ideas? Im just gonna bite the bullit and get a new rack and hopefully be able to exchange the pump, which is only 2 months old, it was a reman'd from NAPA.

This was the first time the car had been on a tow truck since Ive had it. Good thing my friend had 100miles free on his AAA account.



Buy hey its always the fast cars that never make it to the track right lol.
 

·
Registered
Joined
·
139 Posts
The ps has never been on my track car

could you have removed the belt and drove it home or to the track? you just wouldnt of had power steering.
imput from the track is better with manuel mr2 rack modded to fit turns sharper but i drift mine:)
 

·
Registered
Joined
·
1,181 Posts
Discussion Starter · #5 ·
could you have removed the belt and drove it home or to the track? you just wouldnt of had power steering.
No 2j's have serpentine belts so if I removed the belt the car would overheat and drain the battery. It prob happened for a reason though. Still pissed me off seeing a bunch of hondas driving to the track while I was waiting for the tow truck in the gas station.
 

·
Registered
Joined
·
1,953 Posts
Future reference, I have a belt from I believe a Audi 2.0 that fits just the alt, crank, water pump and tensioner. I keep it in the back of the car for this such event. Also it goes on when I go to the track. With a spare breaker bar in the back its a quick 30 second swap.

Dang though, good luck next time.
 

·
Registered
Joined
·
309 Posts
:duh:...wtf was i thinking?...oh, 7mgte i was thinking...guess i need to pay attn more to your sig...if it was a 7m..then youve could of driven it...:thumbsup:..i still think 2JZ's are cool.
i was thinking the same thing, just assumed it was a 5M.
 

·
Registered
Joined
·
1,953 Posts
It is one rib to small, but it only slips at cold start for a second or so. Yes it sits backwards on the tensioner.



I have to look again, as I think the A/C delete belt is from an Audi, I am not sure what this belt is from. I just measured it with a string and went to the parts guys.
 

·
Registered
Joined
·
309 Posts
That's how I imagined it would be. It would be nice to keep as the just in case belt.

It sucks to see a perfectly good mkII on the flatbed. If you need a pully i have a spare one.
 

·
Registered
Joined
·
1,181 Posts
Discussion Starter · #13 ·
Id like to run a belt just around the crank,wp and alt like gus has it but I'm not sure if it would be bad to drive with the grooved belt on a smooth pully. I could machine grooves into the pully at work but I think that would take to much time and wouldn't be worth the effort. I might just get a new rack and tie rods. Gonna find out today if NAPA will exchange the pump.
 

·
Registered
Joined
·
309 Posts
Ya the belt will take out the pulley if you run it the wrong way for too long, but it is a good idea for a temp solution.
 

·
Registered
Joined
·
6,255 Posts
There's a way to reroute the stock belt and delete either the p/s pump or the a/c.....I think it was the a/c. You re-route and it fits :) I've tried it before, but since I was most likely high....I can't remember which accessory it was....Doh!!!
 

·
Registered
Joined
·
1,181 Posts
Discussion Starter · #16 ·
There's a way to reroute the stock belt and delete either the p/s pump or the a/c.....I think it was the a/c. You re-route and it fits :) I've tried it before, but since I was most likely high....I can't remember which accessory it was....Doh!!!
That's how I have it now. I wanted to delete both the ps and ac but it too much of a hassle.

I just exchanged the pump at napa and ill put it on when I get home. For all I know my rack might be good and the old pump was defective or something. Ill find out by the end of the day. I can get a new rack for 200 and a full set of tie rods for about 50 more, so I might just do a whole new rack.
 

·
Registered
Joined
·
1,953 Posts
Ya the belt will take out the pulley if you run it the wrong way for too long, but it is a good idea for a temp solution.
I happen to have the NA's plastic tensioner pulley. No issues running the ribs against it, I have driven the car a few hundred miles like that.
 

·
Registered
Joined
·
309 Posts
I happen to have the NA's plastic tensioner pulley. No issues running the ribs against it, I have driven the car a few hundred miles like that.

Nice.

Down the road I plan on making a idler pulley to take the place of the AC and PS. I figure all you really need is a pulley on a bearing that matches the ribs on the belt. Ill have to check around at work and see if anything matches the JZ belt.

Any more information on a fabrication "less" manual rack?
 

·
Registered
Joined
·
1,077 Posts
Might want to just cut your losses and sell it before you have more problems...

I could take it off your hands for $1000. :laugh:
 
1 - 20 of 35 Posts
Top