Toyota Celica Supra Forum banner

3521 - 3540 of 3619 Posts

·
POTATO
Joined
·
17,252 Posts
The only warning I got was it was hard to start for the last 2 days. i assumed I was running out of gas as it appeared the gauge wasn't working. But Friday night it wouldn't start at all. I checked via the connector at AFM with the key on and no fuel was going to the rail.

Yesterday I plugged in the spare AFM, no go, and then tried another circuit opening relay, still nothing so we dropped the tank.

It was replaced with an OEM Denso unit that was surprisingly in stock for $84.
 

·
Premium Member
Joined
·
5,929 Posts
BARGAIN priced! Same one that is in my'84,now. BACK UP ONE! I paid $92.
14142
 
  • Like
Reactions: Beernuts

·
POTATO
Joined
·
17,252 Posts
14143


I couldn't source both the pump and strainer by Denso so I just got the pump itself from The Parts House, got my strainer from the dealership for $9 (PN doesn't match I just used what I thought would fit)

14144
 

·
Premium Member
Joined
·
5,929 Posts
The 950-0147 needed a little modifying to fit. Denso should be good for a few years. My (back-up )pump will go into my car!I don't recall if I had to buy the strainer separately,but that one comes with one.
Thanks,Tanya!
 

·
Premium Member
Joined
·
5,929 Posts
Small car fire.

Last week,B-4 'Vegas.
I'll change the lower hose,now.Monday.
Pull shroud.Drain left-over coolant.
Attack area with Sing-Pow pressure washer.Dick around with garden hose adapters.
Remove upper hose,first.
Coolant already drained.
Up on ramps:ready.
Remove lower hose and attached burned in-line block heater.
Get another beer.
See if Gates hose actually fits. It does.
Wash fingers,take photo.
Get carried away with pressure washer.
Attach radiator shroud,start engine.
Add collected coolant.
Get another beer.
Drive off ramps.
Watch temp gauge go to 1 billion degrees.
Turn off engine.
Pick up tools and go to my shed.
Wait 2 more days until my coolant gets here.
Go to You Tube and have another beer.

What used to take me 12 minutes now takes me all day.
EYE have time.
 

·
Premium Member
Joined
·
4,036 Posts
I moved a bunch of stuff around in the garage, opened the doors, backed the car out, and swept up the garage.

"Nice Weather" will be returning shortly, and I want to be ready for it!
 

·
Premium Member
Joined
·
5,929 Posts
YES!!!! Nice weather soon. Meet and greets coming. One in Tacoma,WA on the 29th.
Ever seen a V-12 Supra?Mike took it to SIV!
Is the snow gone,yet?
 

·
POTATO
Joined
·
17,252 Posts
I think Mike is postponing the meet on the 29th due to the virus stuff Dave
 

·
Premium Member
Joined
·
4,036 Posts
YES!!!! Nice weather soon. Meet and greets coming. One in Tacoma,WA on the 29th.
Ever seen a V-12 Supra?Mike took it to SIV!
Is the snow gone,yet?

It's pretty much gone here at 5100', but still plenty up in the mountains. Looking at 1"~3" of new snow on Thursday. March is historically our snowiest month, but we've only had a few inches.

I got slowed down on the car quite a bit when my hip started acting up. Did the X-Rays, a bunch of Physical Therapy, and had an MRI done revealing my right hip is about worn-out. Not "metal-to-metal" contact yet, but there's definitely a new hip in the future.
 

·
Premium Member
Joined
·
5,929 Posts
That is a good cautionary decision. I can wait. April may be better. NEW vaccine late April,I read.
I'm hiding in my shed.Supra is mechanically OK,but it needs cleaning.Thanks,Tanya.
 

·
POTATO
Joined
·
17,252 Posts
It's been just under a month since I got the 86 and as of today she has working AC again.

14169


And new hood struts!

14170


A month ago this car was sitting in Miami, not running, parked for 3 years. Now it's my daily driver.

Week:
  • 1. Replaced starter, cleaned engine bay
  • 2. Replaced brake master cylinder, flushed and bled, changed various bulbs
  • 2.5. oil change, coolant flush
  • 3. Replaced fuel pump
  • 3.5. Charged AC, replaced hood struts
 

·
Premium Member
Joined
·
5,929 Posts
Don't paint the car! Ya know,flat black or semi-flat black will GO with(I think that it's dark blue) for the headlight covers.
it looks almost the same shade. I HATE fuel pump changes and I cheated.My third one was it!
I took a page from revv happy and cut out the hatch floor.It's my car and it's paid for.(Rob hates me)Many cars have removable panels to make a fuel pump change MUCH easier.I did make my own removable panel.1/2 hour,solo.
Tanya can blow away most of us,mechanically.She is now a parts driver?Diagnostics is the most difficult part of automotive repair,by far.
This is Dave,cheating. Don't do this!




YOU NEED A/C for Florida! Not for me,so much.
 

·
Premium Member
Joined
·
5,929 Posts
Replaced my alternator. My Chinese volt meter I trust.Drain a little coolant.
Pull shroud and top hose,lower cover.

Hell,I forgot how to do this! I forgot to slightly beat out the bushing in the lower bracket. :rolleyes: An old guy on his back reaches for a hammer...Unusual cuss words follow.Shit falling down into my eyeballs,getting tired. BEER BREAK!🍻

Got 'er done.13.7 V. Now,I'm too tired to put away my toys.My CHINESIUM pressure will just stay there,overnight.⏱:poop:;)
For God's sake ,buy an Americano pressure washer! I like the electric ones.

Painted my lower cover....out of Krylon Fusion paint,so white primer went on,runs and all.


 
  • Like
Reactions: Tanya

·
Registered
Joined
·
112 Posts
You are only getting 13.5 while running?
What's the voltage at the output terminal of the alternator?
 

·
Premium Member
Joined
·
5,929 Posts
13.5 is fine. It's just a 60 A. OH REALLY(?) special.
I did the big 3 and I'm OK with that.
 

·
Registered
Joined
·
112 Posts
You got an SLI battery? Or AGM?
13.5 is more like a float voltage / maintenance level.

Does the MKII temp compensate or just run constant voltage all the time?
 

·
Premium Member
Joined
·
5,929 Posts
It's FLA. It works OK and the regulator was not warmed up during this photo. I'll get 14.2 V. sometimes.
Well,the old one DIED and I'm OK with that new voltage.A group 34 battery.I do keep a trickle charger on that battery unit.It was combined with a block heater that caught fire. Another one on order.

I run LED lights,but not my fog lights,yet. Probably blew the rectum fryer in the regulator. It was 6 years old and it's excused. I had another one in stock.80 or 100 A. alt? Not yet.
I do have an extra AGM,but it is a big monster. My hatch is usually full of ...STUFF.
 

·
Premium Member
Joined
·
5,929 Posts
I got OUT of my shed yesterday. I was low on propane.2 bottles and I'm good to go. Supra runs fine and I was getting 14.2 volts on my Chinese volt meter.That's more like it. ;)
 

·
Premium Member
Joined
·
4,036 Posts
I started Spring Cleaning in the garage today! Should be finished tomorrow, just in time for the next cold front and some snow.
 
3521 - 3540 of 3619 Posts
Top