Toyota Celica Supra Forum banner

1 - 20 of 23 Posts

·
Heroic Autobot
Joined
·
705 Posts
Discussion Starter #1
1990 Buick Skylark Custom four door sedan.

I hated it. It hated me. I traded it in on my current car- 1994 Eagle Talon. But that too seems to be cursed...
 

·
Registered
Joined
·
2,297 Posts
It was a 1979 Triumph TR-7 -- probably the most unreliable car I will ever own. It was my first car too, and I learned a lot about working on cars from it.

However, one day I WOULD like to own a Triumph TR-8, assuming I can find one that is reasonably clean and it's owner doesn't want a MINT for the car.
 

·
Registered
Joined
·
7,111 Posts
1971 Ford Pickup truck dam thing near exploded every time i turned it on. good thing it died a Painful Terrible death ( it caught on fire :lol:)

umm I didnt own it but i drove it to work for a couple of weeks before i got my 83 supra
 

·
Registered
Joined
·
63 Posts
1978 Olds Cutlass. Drove the car for 2 months, ran great up till the end. I think it had some weak V-6 in it, mated to an auto trans. Anyway, I was driving it back to the army base that I was stationed at, and pulling up a hill it began to lose some power. I gunned it and... BOOM!! :shock:

The engine exploded, throwing 3 rods and detonating the Radiator. Talk about a mess. :fist:
 

·
Registered
Joined
·
1,457 Posts
Easy...my 87 mk3 Turbo. What a POS! I don't think there's a part on it I haven't replaced yet.

The car I hated the most, though, was an 87 Conquest Tsi. I'm glad I owned that one for only around 6 mo.

Christian
 

·
Administrator
Joined
·
7,186 Posts
79 cutlass



Car was showroom new, interior/chrome etc. was perfect...and my dad put a killer paint job on it. Bought it in 96 with just 80k old lady miles on it. It sure looked good, but DAMN was it a POS. Trans [email protected], carb went @91k, exhaust manifold [email protected], had a rod knock by 98k....and I totalled it right the motor started knocking....whoops. Me next car was my blue 85...what a difference 8)
 

·
Registered
Joined
·
66 Posts
1982 Chevy Celebrity. 2 door. AM radio. Seriously, AM radio. It was my grandfathers; I tossed my 85 Civic for this (see "Best Car" post). It had 45,000 miles on it when I got it. It went 70mph if I ever drove it off of a cliff. What a total POS. Died on the NJ Turnpike one day, coming home from Ikea loaded with furniture. Hated that f*cking thing.
 

·
Registered User
Joined
·
3,283 Posts
72 Ford Pinto, brown like a turd. The telephone pole did me a favor. :shock:

Mike
 

·
Founding Member
Joined
·
6,434 Posts
Back in high school I traded an old sears pool table for a 79 Honda Civic that he had wrecked. I fixed it up with salvage parts and had it repainted. It looked new and ran pretty good. But there was no A/C. I doubt that tiny motor could've handled an A/C. That was hell here in Texas. I drove it for mabe 8 months, then sold it to a single mom on welfare. On a positive note, it did get something like 36mpg around town.

Phil D.
 

·
Registered
Joined
·
793 Posts
My wife's fully loaded '84 Honda Accord. I swear everytime I see one on the road, I wonder how the hell that person was able to keep it alive!
Godammed thing would stutter on the freeway like it was out of gas, and you had to carry a hammer and brass drift to whack the starter to get it started! Not to mention the speedo died at 26k and the turning signal lever would fall off! :evil:
 

·
Registered
Joined
·
118 Posts
GM SUX!

Bought a brand new 84 Monte Carlo SS...
had torx screws all up one side, and phillips on other
Trace overspray of 3 different colors.
Late nite drive, 100miles from nearest town, moonless, raining.....whole lighting system fries out. Stuck untill dawn.
Couldn't count on POS to start in morning, any morning.
A/C started throwing belts after 7 months.
Smoking blue steady after 10 months.
Internals of distributor blew apart on another drive in middle of nowhere. Rust started within 1 year.
Speedo quit.
Brakes worn out.
Had to visit proctologist after every visit to GM/Chevrolet dealerships (motherfuckingripoffdickwadsassmonkeyselltheirownmotherstowhorehousebuttlickers!!!!!!) :mad:
They ALWAYS found some way of making me cough up $$$ for what should have been warrenty work.
I got hosed for almost $20,000CDN back then, and paid $579/mo for 5 years, even though I traded that POS down for an '80 Camaro, which believe it or not, was an IMPROVEMENT. At least it started every morning.

TOTAL IRONY...I was so pissed at GM that I literally dragged a buddy off a chevy dealer lot, and showed him a new '85 Supra; which he bought, and never had a significant problem. I couldn't afford the Supra, because being a young dumb-ass, I sold my soul to GMAC.

Ken
The only good GM executive is a live GM executive with his guts hanging out, being chewed on by rats and buzzards, lying on an anthill. :evil:
 

·
Registered
Joined
·
1,643 Posts
My first vehicle was a 67 ford F250. Had a early 70's 360 mated to a 4 speed stick with a granny first (could put the truck in 1st and turn the key and start the truck in gear going about .25 mph). I got it for free and it gave me one hell of an education....which wasn't free. I threw some headers on it followed by about 4 feet of dual 2.5" pipe and two glasspacks. Talk about L O U D! Let off the throttle and all you'd hear is machine gun fire. It has a place in the garage in my heart as being my first but that's it.

Nick
 

·
Registered
Joined
·
9,445 Posts
First car:

1976 Datsun B210 Hatchback. ORANGE... And it had the Automatic. Was probably the SLOWEST thing in the world at the time... 1 day I managed to waste 1/4 of a tank of gas trying to keep up w/ a friend who had a 72 240Z. And we had only gone 30 miles. But it got pretty good gas mileage the rest of the time. Only other problem was that anything over 65mph, the motor sounded like it was @ redline (a tach on that car was optional, spent quite a bit of time in the junkyards trying to find one).

A close 2nd place was my Copper Metallic 1980 MA46 MKI. Bought it used from a Buick dealer who had to replace the cracked windshield w/ a replacement one. And as some of you know, the MKI's had the windshield antenna.. This one was pretty bad... Barely had ANY reception on FM, and AM reception was non existant (my current 81 Silver Slug has EXCELLENT reception, being it still has the original windshield)... Then to top it off, in the winter time when it rains allot, I discovered that the windshield had a MAJOR water leak on the front passenger side... Which would become a lake during heavy rain & when it got below freezing, the water & the carpet would freeze.... 8 months after I bought it, the motor would intermittantly cut out/the motor would stop firing... When that happens, the motor would not start from 5 - 20 minutes. Spent $1K trying to fix the problem, but never did get it resolved. 5 years later (in 1992) when I discovered the SOGI list, I found out it was probably the ignitor crapping out. December of 1990, getting tired of dumping more $$$$$$ into this car, I traded it in for the 85 MKII Redpra (which I still have).

Despite the problems I had w/ the 80 Brownpra, I still miss it (mainly because it was a 5-speed) & I sort of wish I could have stuck it out & figured out what the problem was. Oh well.... :p The one GOOD thing that I got out of it, was that the Brownpra was the beginnings of my Supra addiction that continues to this day.. 8)

I later vowed that "eventually" I would acquire another MKI to take it's place, and I accomplished that last May, when I bought the 81 Silver Slug.
 

·
Premium Member
Joined
·
6,119 Posts
1969 Austin American-Veddy British-Prince of Darkness Electrics, Quality mid sixties English union labour, Combined Engine/Tranny case(!!!!)-Had common sump for 40wt (for both)-FWD drivetrain in RWD MG Chassis- Etc. :mad:
 

·
Registered
Joined
·
290 Posts
Since i've only owned 2 cars i'll have to say my first car was my worst. It was a grey 1990 Plymouth Horizon. My dad bought it for me for $1500 from a government auction. It was owned by a hospital and used by nurses(must have been treated nicely). It had 180,000 miles on it :shock: It ran excellent(2.2l 4 banger) and only had one engine problem during the 2 years i owned it. The pick-up coil went out on it and it was a $40 easy fix. It had to get at least 40 miles per gallon. Probably since redline was around 4000rpm and at 3000 rpm a black cloud would blow out the exhaust. I broke the damn door handles off the passenger and drivers side front doors within one week so I had to leave one back door unlocked so I could get in. The rear shocks went bad when I went on a short road trip with 4 people in my back seat :lol: After that if I hit a bump the car would bounce for over a block. It rolled on 13's and of course I had to put some crome wheel covers on them 8)
 

·
Registered
Joined
·
1,613 Posts
84 Ford Thunderchicken. I got it about 3K miles after a factory Ford replacement motor had been put in....

2K after I got it, the rear Main started leaking..
3K... Radiator took a shit...
4.5... Slushbox tranny turned its insides to scrambled eggs
5K a/c quit
8K... voltage regulator screws up and fries the entire charging system, fuse block and ECU (The Mechanic said it was one of those "rare one-in-a-million" breakdowns... I think it was cause this car was one of those rare One-in-a-million pieces of shit..)
At 10K the rear started leaking and whining. Soon as I saw that, I had enough. I bought a $400 GMC pickup with a raised suspension (and a bad rod knock), and went monster truck on it. Sold it to the J-Yard for $75.

Never had another Ford since... and I don't think I ever will.
 

·
Registered
Joined
·
3,433 Posts
worst car i ever had was a 1988 4-cyl ford ranger 5spd, it was my first car and luckily it was free. My mothers boyfriend had pieced together this pos. it had no rear bumper, it had been in an accident and the frame had been welded together from the right front quarter to the middle of the front core support. No radio just a big ol hole in the plastic dash and no radio was able to support in there. glad that thing finally blew up, i had fun acting like it was a 4wd and i took it mud runnin and ran the hell out of it. haha it was a decent go getter though after that i've only had my mkii's
 

·
Registered
Joined
·
257 Posts
please dont hate me :)
an 92 hyundai scoupe
only bought it to resell it to make some $
75,000 miles and 4 rebuilt auto trannies in it 2 warranty and 2 @ $300 a pop
WHAT A PIECE OF SH*T!!!!!!!!!!!!!!!!!
BRIAN
 

·
BIG BOSS HOSS
Joined
·
4,460 Posts
Mine was a '86 VW GTI 1.8. bought it almost new with 30k and what a POS! I owned it for 2 years and replaced almost every coolant hose due to these strange pin hole leaks that kept occurring, replaced the entire exhaust system after the cat decided to disintegrate and plug up the entire system ceramic chunks, replaced the o2 sensor, replaced every belt, water pump, fuel pump and did a complete brake-job at 50k! It also had other problems like losing coolant and the oil light comming on from time to time. I know I'm missing some stuff here but you get the idea. Oh yea, it was made in Canada.

The funny thing is that I had a modded 1980 Scirocco with a swap '84 GTI 1.8 motor /w bolt-ons installed and never had any problems. The Rocco was made in Germany.
 
1 - 20 of 23 Posts
Top